displaying posts 1 to 25 of 26

Pages (2): [1] 2

Author Subject: STOP and oil light on!
chrisd306

Seasoned Pro

Location: Perth Scotland

Registered: 26 Nov 2005

Posts: 10,061

Status: Offline

Post #1
ok my car has came on with the stop light and the oil light, it is flickering on and off an sometimes staying on, its sounding a wee bit chappy aswell topside, oil and everything ok, any ideas??

________________________________________

In my garage just now

2003 BMW M3 & 2009 L200 Raging Bull
& Audi Q5 S Line
AX stock rod & Saxo Stock rod
Sold the bike an charged rallye an bought a caravan, midlife crisis or what!
Posted 7th Sep 2009 at 01:03
chris with a pug

Seasoned Pro

Location: Southampton

Registered: 16 Feb 2003

Posts: 5,366

Status: Offline

Post #2
oil pump?
Posted 7th Sep 2009 at 00:56
chrisd306

Seasoned Pro

Location: Perth Scotland

Registered: 26 Nov 2005

Posts: 10,061

Status: Offline

Post #3
is the pump in the sump on these?

________________________________________

In my garage just now

2003 BMW M3 & 2009 L200 Raging Bull
& Audi Q5 S Line
AX stock rod & Saxo Stock rod
Sold the bike an charged rallye an bought a caravan, midlife crisis or what!
Posted 7th Sep 2009 at 01:03
chris with a pug

Seasoned Pro

Location: Southampton

Registered: 16 Feb 2003

Posts: 5,366

Status: Offline

Post #4
yeah

might be worth checking ur presure first
Posted 7th Sep 2009 at 01:17
chrisd306

Seasoned Pro

Location: Perth Scotland

Registered: 26 Nov 2005

Posts: 10,061

Status: Offline

Post #5
what do you mean by pressure mate? oil pressure? or cylinder compression?? car was still running ok

________________________________________

In my garage just now

2003 BMW M3 & 2009 L200 Raging Bull
& Audi Q5 S Line
AX stock rod & Saxo Stock rod
Sold the bike an charged rallye an bought a caravan, midlife crisis or what!
Posted 7th Sep 2009 at 01:29
xsi-in-stealth

Junior User

Location: carshalton

Registered: 08 Aug 2009

Posts: 84

Status: Offline

Post #6
Is there any power loss at all?

________________________________________

16V-XSi
Posted 7th Sep 2009 at 01:45
chrisd306

Seasoned Pro

Location: Perth Scotland

Registered: 26 Nov 2005

Posts: 10,061

Status: Offline

Post #7
no none at all, but saying that i wasnt revving it or driving it hard to find out, but pulled ok

________________________________________

In my garage just now

2003 BMW M3 & 2009 L200 Raging Bull
& Audi Q5 S Line
AX stock rod & Saxo Stock rod
Sold the bike an charged rallye an bought a caravan, midlife crisis or what!
Posted 7th Sep 2009 at 01:53
PeteB

Seasoned Pro

Location: Didcot

Registered: 15 Jun 2005

Posts: 2,906

Status: Offline

Post #8
The only time i get this is when the oil level is low, check it again when it is cold.

________________________________________

Team Nigel

selling up!!

Posted 7th Sep 2009 at 02:08
chrisd306

Seasoned Pro

Location: Perth Scotland

Registered: 26 Nov 2005

Posts: 10,061

Status: Offline

Post #9
will check it first thing tomorrow once i get to garage plus will have 3 mechanics opinions aswell lol

________________________________________

In my garage just now

2003 BMW M3 & 2009 L200 Raging Bull
& Audi Q5 S Line
AX stock rod & Saxo Stock rod
Sold the bike an charged rallye an bought a caravan, midlife crisis or what!
Posted 7th Sep 2009 at 02:27
xsi-in-stealth

Junior User

Location: carshalton

Registered: 08 Aug 2009

Posts: 84

Status: Offline

Post #10
That's it you don't always notice thing unless your booting it, I've been driving my car for around 3weeks and felt fine and decided to boot it yesterday and I caked the whole 3 lanes of the dual carriage way in a huge cloud of smoke! Then the car went back to normal a few minutes later. It was a huge puff not a gradual build up of smoke, I hit about 50-60 and I heard a puff! don't know what's wrong with it just know somethings knackered!lol

________________________________________

16V-XSi
Posted 7th Sep 2009 at 02:54
chrisd306

Seasoned Pro

Location: Perth Scotland

Registered: 26 Nov 2005

Posts: 10,061

Status: Offline

Post #11
well i had been booting it early on as i had done first 100mile after fitting charger, so was fine, but now light on

________________________________________

In my garage just now

2003 BMW M3 & 2009 L200 Raging Bull
& Audi Q5 S Line
AX stock rod & Saxo Stock rod
Sold the bike an charged rallye an bought a caravan, midlife crisis or what!
Posted 7th Sep 2009 at 03:10
xsi-in-stealth

Junior User

Location: carshalton

Registered: 08 Aug 2009

Posts: 84

Status: Offline

Post #12
Ah sorry mate didn't realise you had a charger, shows how much attention I pay to the forums!lol might be something simple, just worrying that its happened not long after the charger was fitted. Good luck with it anyway mate. Chris

________________________________________

16V-XSi
Posted 7th Sep 2009 at 03:24
chrisd306

Seasoned Pro

Location: Perth Scotland

Registered: 26 Nov 2005

Posts: 10,061

Status: Offline

Post #13
right done a compression check and all cylinders are roughly the same about 200psi so anyone any ideas??

________________________________________

In my garage just now

2003 BMW M3 & 2009 L200 Raging Bull
& Audi Q5 S Line
AX stock rod & Saxo Stock rod
Sold the bike an charged rallye an bought a caravan, midlife crisis or what!
Posted 7th Sep 2009 at 23:08
webster

Seasoned Pro

Location: Colchester

Registered: 20 May 2007

Posts: 2,059

Status: Offline

Post #14
My stop light used to come on when I had an issue with one of the fans - this is probably no help at all but might be worth checking.

________________________________________

cress87 wrote:
I'm stopped for speeding on a daily basis but now the police are aware that I live for the 306 they dare not interfere, just sit in their cars quaking as I drive past.
Posted 7th Sep 2009 at 23:34
adam b

Seasoned Pro

Location: The Nam

Registered: 24 Jan 2006

Posts: 12,828

Status: Offline

Post #15
Could be the wiring from the pressure sender unit? Oil level is ok then I take it?

________________________________________

Nothing to see here
Posted 7th Sep 2009 at 23:35
chrisd306

Seasoned Pro

Location: Perth Scotland

Registered: 26 Nov 2005

Posts: 10,061

Status: Offline

Post #16
let it run for a bit, an its f*cked, its ghot a noisey rattle, would still say it is the top end rather than bottem end!

________________________________________

In my garage just now

2003 BMW M3 & 2009 L200 Raging Bull
& Audi Q5 S Line
AX stock rod & Saxo Stock rod
Sold the bike an charged rallye an bought a caravan, midlife crisis or what!
Posted 8th Sep 2009 at 00:50
gti-si

Regular

Location: Bolton

Registered: 29 May 2008

Posts: 228

Status: Offline

Post #17
unlucky mate, no idea's as towards a cause?

________________________________________

1990 Cherry Red 205 Gti-6
2000 Mitsubishi Galant V6
Posted 8th Sep 2009 at 02:31
chrisd306

Seasoned Pro

Location: Perth Scotland

Registered: 26 Nov 2005

Posts: 10,061

Status: Offline

Post #18
maybe ive dropped a valve, no sure, will whipp head of tomorrow if i have time to do it!! as my old mans garage is busy as f*ck, and im ment to be on holiday from my own work, nae chance!!

________________________________________

In my garage just now

2003 BMW M3 & 2009 L200 Raging Bull
& Audi Q5 S Line
AX stock rod & Saxo Stock rod
Sold the bike an charged rallye an bought a caravan, midlife crisis or what!
Posted 8th Sep 2009 at 02:40
gti-si

Regular

Location: Bolton

Registered: 29 May 2008

Posts: 228

Status: Offline

Post #19
Won't be a dropped valve if you've got good compression over all four cyclinders.

Get a screwdriver on the head and see if you can locate the noise. You positive it isn't a bottom end rattle? If not I'd have the sump off

________________________________________

1990 Cherry Red 205 Gti-6
2000 Mitsubishi Galant V6
Posted 8th Sep 2009 at 03:10
chrisd306

Seasoned Pro

Location: Perth Scotland

Registered: 26 Nov 2005

Posts: 10,061

Status: Offline

Post #20
if i take the sump off, will i be able to see easy enough if there is damage??

________________________________________

In my garage just now

2003 BMW M3 & 2009 L200 Raging Bull
& Audi Q5 S Line
AX stock rod & Saxo Stock rod
Sold the bike an charged rallye an bought a caravan, midlife crisis or what!
Posted 8th Sep 2009 at 03:12
chrisd306

Seasoned Pro

Location: Perth Scotland

Registered: 26 Nov 2005

Posts: 10,061

Status: Offline

Post #21
had goos compression beofre the noise got worse, im thinking a valve has been close to hitting as my heads been skimmed before, and i think that it was myabe nearly hitting and now its hit!! will either have head or sump off it tomorrow or both!! depends how mad the garage is tomorrow like

________________________________________

In my garage just now

2003 BMW M3 & 2009 L200 Raging Bull
& Audi Q5 S Line
AX stock rod & Saxo Stock rod
Sold the bike an charged rallye an bought a caravan, midlife crisis or what!
Posted 8th Sep 2009 at 03:14
xsi-in-stealth

Junior User

Location: carshalton

Registered: 08 Aug 2009

Posts: 84

Status: Offline

Post #22
Sounds like a long day. Hope you've got a box of tricks up your sleeve or a big box of spares!

________________________________________

16V-XSi
Posted 8th Sep 2009 at 03:18
chrisd306

Seasoned Pro

Location: Perth Scotland

Registered: 26 Nov 2005

Posts: 10,061

Status: Offline

Post #23
well need answers so im gonna be in early tomorrow to start!!

________________________________________

In my garage just now

2003 BMW M3 & 2009 L200 Raging Bull
& Audi Q5 S Line
AX stock rod & Saxo Stock rod
Sold the bike an charged rallye an bought a caravan, midlife crisis or what!
Posted 8th Sep 2009 at 03:20
xsi-in-stealth

Junior User

Location: carshalton

Registered: 08 Aug 2009

Posts: 84

Status: Offline

Post #24
Yeah that's best thing get an early start. Mine more than likely needs new valve but I want to fit a new engine if it doesn't sell, never fitted an engine but might just give it a go.

________________________________________

16V-XSi
Posted 8th Sep 2009 at 03:23
chrisd306

Seasoned Pro

Location: Perth Scotland

Registered: 26 Nov 2005

Posts: 10,061

Status: Offline

Post #25
bottem end!!

________________________________________

In my garage just now

2003 BMW M3 & 2009 L200 Raging Bull
& Audi Q5 S Line
AX stock rod & Saxo Stock rod
Sold the bike an charged rallye an bought a caravan, midlife crisis or what!
Posted 8th Sep 2009 at 14:06

Pages (2): [1] 2

All times are GMT. The time is now 01:06

The Peugeot GTi-6 & Rallye Owners Club - ©2024 all rights reserved.

Please Note: The views and opinions found herein are those of individuals, and not of The Peugeot 306 GTi-6 & Rallye Owners Club or any individuals involved.
No responsibility is taken or assumed for any comments or statements made on, or in relation to, this website. Please see our updated privacy policy.