displaying posts 1 to 4 of 4

Author Subject: Interior blower not working
MagnusMJ

Newbie

Location: Herlufmagle

Registered: 11 Apr 2017

Posts: 5

Status: Offline

Post #1
Hello!

Recently my blower stopped working. The heater works fine.
I tried to rotate the blower by sticking my hand down from the engine bay, and it rotates just fine. I checked all fuses, and they seem to be fine.

Hope you guys can help me out.
Posted 31st Jan 2020 at 21:00
prism7guy

Seasoned Pro

Location: DoncastAAAAARGH

Registered: 13 Jan 2008

Posts: 4,614

Status: Offline

Post #2
Tried checking the connector that plugs into the motor is seeing 12V?

________________________________________

Goldie the track car.
Posted 31st Jan 2020 at 21:23
MagnusMJ

Newbie

Location: Herlufmagle

Registered: 11 Apr 2017

Posts: 5

Status: Offline

Post #3
I just tried, there is no electricity coming to the motor
Just found out that theres always 12v in the red wire, but no electricity in the other 4 no matter what fan speed I choose.
Posted 1st Feb 2020 at 11:34
MagnusMJ

Newbie

Location: Herlufmagle

Registered: 11 Apr 2017

Posts: 5

Status: Offline

Post #4
Removed the motor and gave direct 12v with a spare battery, it works fine
Posted 1st Feb 2020 at 11:54

We Wiser Insurance Scheme
All times are GMT. The time is now 17:32

The Peugeot GTi-6 & Rallye Owners Club Ltd - Registered in England & Wales - Reg No: 07410694 - ©2021 all rights reserved.

Please Note : The views and opinions found herein are those of individuals, and not of The Peugeot 306 GTi-6 & Rallye Owners Club Ltd or any individuals involved.
No responsibility is taken or assumed for any comments or statements made on, or in relation to, this website. Please see our updated privacy policy and legal information