displaying posts 1 to 25 of 30

Pages (2): [1] 2

Author Subject: no power throughout revs.
allesclar

Seasoned Pro

Location: Sheffield

Registered: 17 May 2009

Posts: 4,254

Status: Offline

Post #1
Hey all,

The car will go ok, no hesitation in the revs or gears etc, but its as if i have only half the power and seem to be making abit more breathing noise.

I have checked the coil packs and the charger itself.

my only thought is it could be the sports cat i had put in 2 and a half years ago, but could it have burnt out already by now?

when i drove back and put my foot down, there is only a tiny bit of power and it seems as if the car is struggling or something is restricting it.

any other thoughts?

Adam

________________________________________

Team allesclar ®

Posted 27th Feb 2012 at 19:32
darkgti6

Seasoned Pro

Location: Bracknell

Registered: 07 Jun 2008

Posts: 1,358

Status: Offline

Post #2
Have you checked all of your boost pipe work and intercooler for leaks?

________________________________________

Team Peugeot Sport 308 Gti

Black T'99 Gti - may she rest in peace - written off in a shunt on the A329m
Posted 27th Feb 2012 at 19:42
allesclar

Seasoned Pro

Location: Sheffield

Registered: 17 May 2009

Posts: 4,254

Status: Offline

Post #3
i have had a look yes, but my understanding was because the charger bolts straight onto the inlet manifold, if there was a leak, surely it would be boosting?

________________________________________

Team allesclar ®

Posted 27th Feb 2012 at 19:47
birk

Seasoned Pro

Location: Doncaster

Registered: 24 Oct 2005

Posts: 7,032

Status: Offline

Post #4
Yea it would.

________________________________________

Dimma + Gt35 turbo = Ninja
Solid rear beam mounts £130
07889376885
Dan
Posted 27th Feb 2012 at 19:50
allesclar

Seasoned Pro

Location: Sheffield

Registered: 17 May 2009

Posts: 4,254

Status: Offline

Post #5
first thoughts birk?

________________________________________

Team allesclar ®

Posted 27th Feb 2012 at 20:17
birk

Seasoned Pro

Location: Doncaster

Registered: 24 Oct 2005

Posts: 7,032

Status: Offline

Post #6
1st thoughts would be a blocked/collapsed boost pipe.

I had one completely suck itself shut and it wouldn't pop back out.

________________________________________

Dimma + Gt35 turbo = Ninja
Solid rear beam mounts £130
07889376885
Dan
Posted 27th Feb 2012 at 20:33
allesclar

Seasoned Pro

Location: Sheffield

Registered: 17 May 2009

Posts: 4,254

Status: Offline

Post #7
well its all metal, bar the elbow on the charger itself and the first metal pipe, but i have looked there and it seems normal :S

________________________________________

Team allesclar ®

Posted 27th Feb 2012 at 20:34
allesclar

Seasoned Pro

Location: Sheffield

Registered: 17 May 2009

Posts: 4,254

Status: Offline

Post #8
well just to add, it has had a charger oil and filter renewal only last august and 1000 miles later. i am thinking it might be something to do with the exhaust system, as someone mentioned the CAT could have collapsed.

could this cause this problem, i had the sports CAT installed just under 3 years ago, most of it has been with the charger installed, could it really die that quickly? i will be going decat if so.

________________________________________

Team allesclar ®

Posted 27th Feb 2012 at 20:52
phillipm

Seasoned Pro

Location: Rotherham

Registered: 15 Oct 2006

Posts: 20,601

Status: Offline

Post #9
Could do with the extra heat/pressure - what make was the CAT?

________________________________________

- Bespoke rollcages/additions/adjustments. Half cages right up to complete custom spaceframes - MSA/FIA spec, CDS, ROPT, T45, etc - PM me
Email me!
Custom-made polybushes available - need an odd size or fitment? - anything from batch work to one-off pieces.
Posted 27th Feb 2012 at 20:54
smegal

Seasoned Pro

Location: Leeds

Registered: 26 Dec 2005

Posts: 5,940

Status: Offline

Post #10
When my sports cat collapsed, mine wouldn't rev past 5k. It did show those symptoms before. If you unbolt the cat from the exhaust, and have a look.

________________________________________

Ex SC-6

Now in a Megane R26
Posted 27th Feb 2012 at 21:30
allesclar

Seasoned Pro

Location: Sheffield

Registered: 17 May 2009

Posts: 4,254

Status: Offline

Post #11
ah ok,

and barely any power but lots of noise smegal?

silly question i know, but is it ok for me to take the sports cat out and give it a quick try, not moving but reving slightly?

________________________________________

Team allesclar ®

Posted 27th Feb 2012 at 21:52
smegal

Seasoned Pro

Location: Leeds

Registered: 26 Dec 2005

Posts: 5,940

Status: Offline

Post #12
It will be LOUD! sounds amazing though.

________________________________________

Ex SC-6

Now in a Megane R26
Posted 27th Feb 2012 at 21:55
birk

Seasoned Pro

Location: Doncaster

Registered: 24 Oct 2005

Posts: 7,032

Status: Offline

Post #13
Yea will be fine, sounds mint, pop pop BANG BANG Smile

Easiest way to find out.

________________________________________

Dimma + Gt35 turbo = Ninja
Solid rear beam mounts £130
07889376885
Dan
Posted 27th Feb 2012 at 22:36
simonjames

Seasoned Pro

Location: Whitland S.Wales

Registered: 23 Nov 2004

Posts: 6,220

Status: Offline

Post #14
Mine wouldnt rev over 4k when i had a faulty pump

________________________________________

All South Wales Members Click Here
Team Supercharged Black RALLYE (Click Here for Build Project)
MY EBAY ITEMS

07943066306
Posted 27th Feb 2012 at 22:42
allesclar

Seasoned Pro

Location: Sheffield

Registered: 17 May 2009

Posts: 4,254

Status: Offline

Post #15
what pump Simon?

________________________________________

Team allesclar ®

Posted 27th Feb 2012 at 22:54
birk

Seasoned Pro

Location: Doncaster

Registered: 24 Oct 2005

Posts: 7,032

Status: Offline

Post #16
Fuel pump I imagine.

________________________________________

Dimma + Gt35 turbo = Ninja
Solid rear beam mounts £130
07889376885
Dan
Posted 28th Feb 2012 at 08:33
allesclar

Seasoned Pro

Location: Sheffield

Registered: 17 May 2009

Posts: 4,254

Status: Offline

Post #17
someone at work suggested the cambelt might have slippped? got it booked in on Friday, annoyingly longlife warranty only covers the cat for 12 months. if that is the case, I will decay and sell the cat for scrap.

________________________________________

Team allesclar ®

Posted 28th Feb 2012 at 17:23
swiftyboi006

Seasoned Pro

Location: Maidenhead

Registered: 12 Apr 2010

Posts: 2,110

Status: Offline

Post #18
As above cat off and rev it. BANG POP neighbours round

________________________________________

cherry p1.....SOLD (regreting this)
blaze p2.....why did i buy this SOLD
Black p3 Love
Posted 28th Feb 2012 at 18:32
stan_306gti6 Forum Admin

Location: Kent

Registered: 18 Jan 2004

Posts: 21,784

Status: Offline

Post #19
swiftyboi006 wrote:
BANG POP neighbours round


LOL

Happened to you before has it?

________________________________________

"Supercharged - 454.1bhp/317.5lb/ft"
Peugeot 306 GTi-6
2000 (X), Moonstone Love
Posted 28th Feb 2012 at 19:14
smegal

Seasoned Pro

Location: Leeds

Registered: 26 Dec 2005

Posts: 5,940

Status: Offline

Post #20
If the belt had slipped it would be idling really rough!

________________________________________

Ex SC-6

Now in a Megane R26
Posted 28th Feb 2012 at 19:20
allesclar

Seasoned Pro

Location: Sheffield

Registered: 17 May 2009

Posts: 4,254

Status: Offline

Post #21
thats what i thought Razz

________________________________________

Team allesclar ®

Posted 28th Feb 2012 at 19:32
allesclar

Seasoned Pro

Location: Sheffield

Registered: 17 May 2009

Posts: 4,254

Status: Offline

Post #22
swiftyboi006 wrote:
As above cat off and rev it. BANG POP neighbours round


ha made me chuckle.

________________________________________

Team allesclar ®

Posted 28th Feb 2012 at 19:35
smegal

Seasoned Pro

Location: Leeds

Registered: 26 Dec 2005

Posts: 5,940

Status: Offline

Post #23
You're down south aren't you atm?

________________________________________

Ex SC-6

Now in a Megane R26
Posted 28th Feb 2012 at 19:35
allesclar

Seasoned Pro

Location: Sheffield

Registered: 17 May 2009

Posts: 4,254

Status: Offline

Post #24
yes mate, in watford.

________________________________________

Team allesclar ®

Posted 28th Feb 2012 at 20:05
smegal

Seasoned Pro

Location: Leeds

Registered: 26 Dec 2005

Posts: 5,940

Status: Offline

Post #25
Fair doos, if you find yourself up here. Give me a shout and I'll plug it in. Mine was giving lambda errors when the cat was f*cked.

________________________________________

Ex SC-6

Now in a Megane R26
Posted 28th Feb 2012 at 20:08

Pages (2): [1] 2

1988 Ford Escort

  • 2000cc
  • Green
  • 0 miles

£3,500

Location: hertfordshire

All times are GMT. The time is now 00:07

The Peugeot GTi-6 & Rallye Owners Club Ltd - Registered in England & Wales - Reg No: 07410694 - ©2023 all rights reserved.

Please Note : The views and opinions found herein are those of individuals, and not of The Peugeot 306 GTi-6 & Rallye Owners Club Ltd or any individuals involved.
No responsibility is taken or assumed for any comments or statements made on, or in relation to, this website. Please see our updated privacy policy and legal information